Dr. Michael Kroll's Mobile Computing Forum
http://forum.mkroll.mobi/

RX not updating on iPhone
http://forum.mkroll.mobi/viewtopic.php?f=1&t=544
Page 1 of 1

Author:  davidbliss [ Wed Mar 20, 2013 8:16 pm ]
Post subject:  RX not updating on iPhone

Hi,

I have tested my own sketch and the sketch from the site, but can't get data updated on the iPhone.

I can see that the buffer length is updating.

I have tried both manually clicking the read button and turning on notifications within BLEExplr.

I am able to send data to the shield.

Any thoughts on what I might have wrong? Should print and println work as well as write? (I've tried them all).

Author:  davidbliss [ Wed Mar 20, 2013 10:16 pm ]
Post subject:  Re: RX not updating on iPhone

Actually, I just discovered that power cycling the BLE board seems to fix some of my trouble.

From what I see, I need to send exactly 16 bytes. Anything fewer and they wait in the cache until there are 16.

Anything more and the cache must be cleared before anything is sent.

From what I can tell, if I go beyond 16 bytes, I have to flush the cache (by sending 0x01 to the clear cache service) and lose all the bytes in the cache. Can you confirm there is no way to send the first 16 bytes in the cache and then recover what is overflowing?

Author:  mkroll [ Thu Mar 21, 2013 10:28 am ]
Post subject:  Re: RX not updating on iPhone

Hello David,
yes, that's the way it goes with firmware v1.0.0 or v1.0.1.
Version 1.1 of the firmware will change this behavior but it is still under development.

But since it is open source, you are welcome to contribute and share changes to the firmware to the community.

Cheers,
Michael.

Page 1 of 1 All times are UTC + 1 hour [ DST ]
Powered by phpBB® Forum Software © phpBB Group
http://www.phpbb.com/